VMware VSAN APD Issue – HPE Smart Array Controller Firmware and Driver

Expected VSAN certified driver and firmware for HPE P416ie-m ve P204i-c smart array controller are published. Links are below. You may say ” this is normal situation, any vendor regularly publish a new driver and firmware version”. You are right. But newly published these versions are very important if you use VMware VSAN on HPE Synergy and upgraded to vSphere 6.7 U2. Also I hit this bug in my VSAN enabled cluster, all virtual machine went down last Sunday while doing a maintenance operation. All ESXi host in this cluster issued “All Path Down (APD)” error and VM machine was inaccessible. So I was following up the HPE Advisory regarding this topic and waiting for approximately one month to have these new tested/VSAN certified driver and firmware updates.

The error message on ESXi host when the case occured is below:

Also the IO failure is seen on virtual machine in case of failure.

Buggy firmware and driver versions are below. Also HPE noticed in the advisory document that similiar cases may be happened with other versions which are under the published versions.

Model         : HPE P416ie-m Smart Array Controller

Firmware     : 1.98

Driver         : smartpqi

Driver    Version    : 1.0.3.2302-1OEM.670.0.0.8169922

Model         : HPE P204i-c Smart Array Controller

Firmware    : 1.98

Driver         : smartpqi

Driver Version    : 1.0.3.2302-1OEM.670.0.0.8169922

Please update your environment with the following versions if you have VSAN enabled cluster runs on HPE Synergy servers with the defined smart array controller cards and if you want to upgrade to vSphere 6.7 U2.

Recommended version for smart array controller as stated above is firmware 1.99 and driver 1.0.3.2309-1OEM.670.0.0.8169922

HPE Firmware Link: https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_a0d218762f5e49a3861d982817#tab-history

VMware Driver Link: https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI67-MICROSEMI-SMARTPQI-1032309&productId=742

HPE Advisory Link: https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00071158en_us

On the other hand, dont forgot to apply the latest HPE Synergy SPP bundle to your servers and chasis with virtual connect modules.

You can follow the updates something like this from VMware VSAN Compatibility Guide website.

Link : https://www.vmware.com/resources/compatibility/search.php?deviceCategory=vsan

When you connect the website if you dont use VSAN ready nodes like me, go to “Build Your Own based on Certified Components” link which is located in the middle of the website. Then type your product model to see the certified and tested firmware/driver versionu bulabilirsiniz.

I recommend take action immediately if you have same components to avoid data loss/corruption or service outage.

Thanks to VMware TR and HPE TR teams for their excellent support every time for HPE Synergy and VMware VSAN topics.

Leave a Reply

Your email address will not be published. Required fields are marked *